Задать вопрос
28 февраля, 13:12

Дан массив А из 20 элементов. найти сумму первых 10 элементов массива и следующих 10 элементов массива. результат вывести на печать.

+5
Ответы (1)
  1. 28 февраля, 16:57
    0
    Var a : array[1 ... 20] of integer;

    i, s1, s2 : integer;

    begin

    ... считали массив

    s1 : = 0;

    s2 : = 0;

    for i : = 1 to 10 do

    s1 : = s1 + a[i];

    for i: = 11 to 20 do

    s2 : = s2 + a[i];

    writeln ('сумма 1-10 = ', s1, '; сумма 11-20 = ', s2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив А из 20 элементов. найти сумму первых 10 элементов массива и следующих 10 элементов массива. результат вывести на печать. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)