Задать вопрос
10 июля, 20:17

Дана строка, выбрать из нее все цифры и упорядочить по возрастанию. (паскаль АВС)

+2
Ответы (1)
  1. 10 июля, 22:48
    0
    Var

    a : array ['0' ... '9'] of integer;

    s : string;

    i : integer;

    j : char;

    begin

    readln (s) ;

    for i : = 1 to length (s) do

    if s[i] in ['0' ... '9'] then inc (a[s[i]]) ;

    for j : = '0' to '9' do

    for i : = 1 to a[j] do

    write (j) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана строка, выбрать из нее все цифры и упорядочить по возрастанию. (паскаль АВС) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)