Задать вопрос
1 ноября, 22:52

Дано: n-натуральное число (longint). Вычислить среднее геометрическое цифр больших единицы. Составить программу в Паскале

+3
Ответы (1)
  1. 2 ноября, 00:03
    0
    Var

    n:longint;

    i, s, p, y:integer;

    t:string;

    x:real;

    begin

    write ('Введите число: ') ;

    readln (n) ;

    p:=1;

    t:=IntToStr (n) ;

    for i:=1 to length (t) do

    begin

    y:=StrToInt (t[i]) ;

    if y>1 then

    begin

    s:=s+1;

    p:=p*y

    end;

    end;

    x:=exp (ln (p) / s) ;

    writeln ('Среднее геом. цифр больших единицы: ', x)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано: n-натуральное число (longint). Вычислить среднее геометрическое цифр больших единицы. Составить программу в Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задачи по информатике, нужно в Паскале сделать программы: 2. Дано натуральное n. Вычислить n!; среднее арифметическое чисел от 1 до n; и среднее геометрическое от 1 до n. 3. Вводится натуральное число a.
Ответы (1)
Написать программу на Паскале. Дано натуральное число. Вычислить среднее геометрическое нечетных цифр.
Ответы (1)
6.22) Дано натуральное число. Определить: а) количество цифр 3 в нем; б) сумму его цифр, больших пяти; в) произведение его цифр, больших семи; 6.26) Дано натуральное число. а) определить его максимальную цифру. б) определить его минимальную цифру.
Ответы (1)
Дано натуральное число n. Найти среднее геометрическое первой и последней цифр заданного числа. помогите написать программу в паскале.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)