Задать вопрос
28 января, 03:28

Написать программу на Паскале. Дано натуральное число. Вычислить среднее геометрическое нечетных цифр.

+2
Ответы (1)
  1. 28 января, 07:01
    0
    Var n, c, d, p: integer;

    begin

    readln (n) ;

    p : = 1;

    while n0 do begin

    d : = n mod 10;

    n : = n div 10;

    if d mod 2 = 1 then begin

    p : = p * d;

    c : = c + 1;

    end;

    end;

    if c = 0 then writeln (0)

    else writeln (Exp (Ln (p) / c) : 0:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Паскале. Дано натуральное число. Вычислить среднее геометрическое нечетных цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задачи по информатике, нужно в Паскале сделать программы: 2. Дано натуральное n. Вычислить n!; среднее арифметическое чисел от 1 до n; и среднее геометрическое от 1 до n. 3. Вводится натуральное число a.
Ответы (1)
Дано: n-натуральное число (longint). Вычислить среднее геометрическое цифр больших единицы. Составить программу в Паскале
Ответы (1)
Дано натуральное число n. Найти среднее геометрическое первой и последней цифр заданного числа. помогите написать программу в паскале.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)