Задать вопрос
8 ноября, 00:35

Дано натуральное число n. Найти среднее геометрическое первой и последней цифр заданного числа.

помогите написать программу в паскале.

+1
Ответы (1)
  1. 8 ноября, 02:43
    0
    Var

    n, c:integer;

    Begin

    Write ('n = ') ; ReadLn (n) ;

    c:=n mod 10;

    While n div 10 > 0 do

    n:=n div 10;

    WriteLn (Sqrt (n*c))

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число n. Найти среднее геометрическое первой и последней цифр заданного числа. помогите написать программу в паскале. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Дано натуральное число n. Найти отношение последней цифры к первой цифре заданного числа. Помогите написать программу в Паскале.
Ответы (1)
Задачи по информатике, нужно в Паскале сделать программы: 2. Дано натуральное n. Вычислить n!; среднее арифметическое чисел от 1 до n; и среднее геометрическое от 1 до n. 3. Вводится натуральное число a.
Ответы (1)
Написать программу на Паскале. Дано натуральное число. Вычислить среднее геометрическое нечетных цифр.
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)