Задать вопрос
6 января, 22:15

Дано натуральное число n. Найти отношение последней цифры к первой цифре заданного числа.

Помогите написать программу в Паскале.

+5
Ответы (1)
  1. 7 января, 00:02
    0
    Var

    n, i, p1, p2: integer;

    begin

    read (n) ;

    p2 : = n mod 10;

    while n > 0 do

    begin

    if (n div 10 < = 0) then p1 : = (n mod 10) ;

    n : = n div 10;

    end;

    write (p2 / p1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число n. Найти отношение последней цифры к первой цифре заданного числа. Помогите написать программу в Паскале. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число n. Найти среднее геометрическое первой и последней цифр заданного числа. помогите написать программу в паскале.
Ответы (1)
Дано целое положительное четырехзначное число. Напишите программу, позволяющую определить двузначное число, в котором число десятков соответствует первой цифре заданного числа, а число единиц-последней. Например: 3234 = > 34.
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
Дано натуральное число n. Определить, во сколько раз произведение всех цифр заданного числа больше его первой цифры. помогите написать программу в паскале.
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)