Задать вопрос
18 октября, 21:27

Дан массив x целых чисел. Исключить из него все числа, встречающиеся более двух раз (если такие имеются). Затем числа, стоящие на четных местах, упорядочить по невозрастаниюПрограмма необходима на языке Pascal

+5
Ответы (1)
  1. 18 октября, 22:45
    0
    uses crt;

    const nmax=100;

    var x:array[1 ... nmax] of integer;

    n, m, i, j, k, a, p:integer;

    begin clrscr;

    randomize;

    repeat

    write ('Размер массива от 2 до ', nmax,' n=') ;

    readln (n) ;

    until n in [2 ... nmax];

    writeln ('Исходный массив:') ;

    for i:=1 to n do

    begin

    x[i]:=random (10) ;

    write (x[i]:4) ; end;

    writeln; i:=1;

    m:=n;

    while i
    begin

    k:=1;

    a:=x[i];

    for j:=n downto i+1 do

    if x[j]=a then k:=k+1;

    if k>2 then

    begin

    j:=i;

    while j<=n do

    if x[j]=a then

    begin

    if j=n then n:=n-1

    else

    begin

    for p:=j to n-1 do

    x[p]:=x[p+1];

    n:=n-1;

    end;

    end

    else j:=j+1;

    end

    else i:=i+1;

    end; if n=0 then

    begin

    exit

    end;

    if n=m then

    write ('Все элементы встречены не более 2 раз и не удалены') else

    begin

    for i:=1 to n do write (x[i]:4) ;

    for i:=1 to n-1 do

    for j:=i+1 to n do

    if (i mod 2=0) and (j mod 2=0) and (x[i]
    begin

    a:=x[i];

    x[i]:=x[j];

    x[j]:=a;

    end;

    for i:=1 to n do

    write (x[i]:4) ;

    end;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив x целых чисел. Исключить из него все числа, встречающиеся более двух раз (если такие имеются). Затем числа, стоящие на четных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Дан массив А (20). Переписать элементы этого массива, стоящие на четных местах, подряд в массив В, а стоящие на нечетных местах - в массив С. Все три массива отпечатать. (сложнА, знаю) хыхыхы
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Написать программу: 1) сформировать массив из 18 целых случайных чисел из [-35; 35], вывести исходный массив в строку; 2) найти среднее арифметическое всех четных элементов массива; 3) найти сумму неотрицательных элементов;
Ответы (1)