Задать вопрос
5 января, 21:55

Нарисовать олимпийские кольца в abc pascal

+1
Ответы (2)
  1. 5 января, 22:21
    0
    Сначала обычный шаблон паскаля (program, var и т. д.)

    потом writeln ( ...) там рисуешь кольца с помощью разных знаков (/. _ - |/)
  2. 6 января, 00:36
    0
    uses graphABC;

    function ris (x, y, r, n:integer) : integer;

    begin

    if n=0 then ris:=0

    else

    begin

    circle (x, y, r) ;

    dec (n) ;

    ris:=ris (x+round ((r-r/3) * cos (pi/3)), y-round ((r-r/3) * sin (pi/3)), r div 3, n) ; ris:=ris (x+round ((r-r/3) * cos (2*pi/3)), y-round ((r-r/3) * sin (2*pi/3)), r div 3, n) ; ris:=ris (x+round ((r-r/3) * cos (pi)), y-round ((r-r/3) * sin (pi)), r div 3, n)

    ris:=ris (x+round ((r-r/3) * cos (4*pi/3)), y-round ((r-r/3) * sin (4*pi/3)), r div 3, n) ; ris:=ris (x+round ((r-r/3) * cos (5*pi/3)), y-round ((r-r/3) * sin (5*pi/3)), r div 3, n) ; ris:=ris (x+round ((r-r/3) * cos (2*pi)), y-round ((r-r/3) * sin (2*pi)), r div 3, n) ;

    end

    end;

    var x, y:integer;

    begin

    x:=windowwidth div 2;

    y:=windowheight div 2;

    ris (x, y, 200,5) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нарисовать олимпийские кольца в abc pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
Как нарисовать олимпийские кольца в PascalABC?
Ответы (1)