Задать вопрос
22 января, 10:42

Дано трехзначное число. Вывести "Yes", если его цифры образуют возрастающую или убывающую последовательность. В противном случае вывести "No".

+2
Ответы (1)
  1. 22 января, 14:33
    0
    Const N=10;

    var i, b, s: integer;

    a: string;

    begin

    readln (b) ;

    a : = inttostr (b) ;

    for i : = 1 to length (a) do

    if (strtoint (a[i]) > s) then

    s : = strtoint (a[i])

    else

    s:=10;

    if (s = 10) then writeln ('No') else writeln ('Yes') ;

    end.

    Удачи =)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано трехзначное число. Вывести "Yes", если его цифры образуют возрастающую или убывающую последовательность. В противном случае вывести ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу, печатающую значение 1, если указанное высказывание является истинным, и 0 в противном случае: цифры данного двузначного числа N образуют строго возрастающую последовательность
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Дано число. Если оно делится на 11, то уменьшить ч Дано число. Если оно делится на 11, то уменьшить число в 11 раз, в противном случае уменьшить число на 11. исло в 11 раз, в противном случае уменьшить число на 11.
Ответы (1)
Дана последовательность целых чисел, оканчивающаяся числом 100. Определить, есть ли в последовательности число 77. Если такое число есть, то вывести "Yes". В противном случае вывести "No".
Ответы (2)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)