Задать вопрос
16 июля, 19:01

Дана последовательность целых чисел, оканчивающаяся числом 100. Определить, есть ли в последовательности число 77. Если такое число есть, то вывести "Yes". В противном случае вывести "No". Решить данную задачу двумя способами, используя циклы с пред и пост условиями.

+2
Ответы (2)
  1. 16 июля, 19:52
    0
    1) Первый способ:

    program one;

    var a, b:integer;

    begin

    b:=0;

    readln (a) ;

    while a100 do

    begin

    if a=77 then

    begin

    b:=b+1;

    readln (a) ;

    end

    else readln (a) ;

    end;

    if b>0 then writeln ('Yes')

    else writeln ('No') ;

    end.

    2) Второй способ:

    program one;

    var a, b:integer;

    begin

    b:=0;

    repeat

    readln (a) ;

    if a=77 then b:=b+1;

    until a=100;

    if b>0 then writeln ('Yes')

    else writeln ('No') ;

    end.
  2. 16 июля, 21:27
    0
    Program spos;

    uses crt;

    var

    numb:array [1 ... 100] of byte; / / для последовательности чисел

    i, f:integer; / / счетчик и переменная в качестве флага

    begin

    randomize;

    f:=0;

    for i:=1 to 100 do numb[i]:=random (101) ; / / задает последовательность

    for i:=1 to 100 do

    begin

    write (',', numb[i]) ; / / вывод на экран последовательность (можно удалить)

    if (numb[i]=77) then f:=1; / / в случае удачной проверки f:=1, в противном останется 0

    end;

    if f=0 then writeln ('Yes') else writeln ('No') ;

    end.

    program spos;

    uses crt;

    var

    numb:array [1 ... 100] of byte; / / для последовательности чисел

    i, f:integer; / / счетчик и переменная в качестве флага

    begin

    randomize;

    f:=0;

    for i:=1 to 100 do begin

    numb[i]:=random (101) ; / / задает последовательность

    write (' ', numb[i]) ; / / вывод на экран, можно удалить

    end;

    writeln;

    i:=0;

    repeat

    i:=i+1;

    if (numb[i]=77) then f:=1; / / в случае удачной проверки f:=1, в противном останется 0

    until i<100;

    if f=0 then writeln ('Yes') else writeln ('No') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность целых чисел, оканчивающаяся числом 100. Определить, есть ли в последовательности число 77. Если такое число есть, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Определите сумму всех элементов последовательности, завершающейся числом 0. Числа, следующие за нулем, считывать не нужно. Входные данные Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит).
Ответы (1)
Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c.
Ответы (1)
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке.
Ответы (1)