Задать вопрос
27 ноября, 20:04

Напечатать все целые числа от а до б и квадраты всех целых чисел от а до б через for и while.

+4
Ответы (1)
  1. 27 ноября, 21:35
    0
    Var a, i, b: integer;

    begin

    readln (a, b) ;

    for i : = a to b do

    writeln (i, ' ', sqr (i)) ;

    i : = a;

    while (i < = b) do

    begin

    writeln (i, ' ', sqr (i)) ;

    inc (i) ;

    end;

    end.

    В одной программе оба подхода =)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напечатать все целые числа от а до б и квадраты всех целых чисел от а до б через for и while. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напечатать столбиком: a) все целые числа от 10 до 35; b) квадраты все целых чисел от 5 до n; c) третьи степени всех целых чисел от а до 50; d) все целые числа от а до b. Использовать оператор While
Ответы (1)
Паскаль 5.3 Напечатать "столбиком": а) все целые числа от 20 до 35 б) квадраты всех целых чисел от a до 50 (значение a вводится с клавиатуры; b>=10) в) третьи степени всех целых чисел от a до 50 (значение a вводится с клавиатуры; a
Ответы (1)
Составить программу в Pascal, используя цикл с счетчиком for 1. Напечатать квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b>10) 2. Напечатать все целые числа от a до b (значения a и b вводятся с клавиатуры)
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)