Задать вопрос
19 апреля, 09:20

Составить программу, находящую кол-во и сумму цифр пяти данных целых чисел, используя процедуру

+3
Ответы (1)
  1. 19 апреля, 12:10
    0
    Var i, x, k, s:integer;

    function Sum (x:integer) : integer;

    var

    t:string;

    i:integer;

    begin

    s:=0;

    t:=IntToStr (x) ;

    for i:=1 to length (t) do s:=s+StrToInt (t[i]) ;

    result:=s

    end;

    function Kol (x:integer) : integer;

    var t:string;

    begin

    t:=IntToStr (x) ;

    result:=length (t)

    end;

    begin

    for i:=1 to 5 do

    begin

    write ('Введите число ', i,': ') ;

    readln (x) ;

    k:=Kol (x) ;

    s:=Sum (x) ;

    writeln ('Количество цифр ', k,'; сумма цифр ', s)

    end

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, находящую кол-во и сумму цифр пяти данных целых чисел, используя процедуру ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Описать процедуру SumDigit (N, S), находящую сумму цифр S целого числа N (N - входной, S - выходной параметр). Используя эту процедуру, найти суммы цифр пяти данных чисел.
Ответы (1)
1. составить программу и алгоритм находящую сумму цифр трехзначного числа 2. составить программу и алгоритм находящую все простые делители заданного числа
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
1 Написать процедуру вычисления среднего арифметического двух чисел. Числа и результат передаются в качестве параметров , в каком из двух введенных с клавиатуры целых чисел произведение цифр больше.
Ответы (1)