Задать вопрос
17 декабря, 02:58

Написать программу чтоб работала в Pascal

запрашивает с клавиатуры три произвольных числа и выводит на экран сообщение о том, сколь - ко из них отрицательных, положительных и нулевых.

+5
Ответы (2)
  1. 17 декабря, 03:24
    0
    Program pr; var a, b, nul, otr, pol, c:integer; begin write ('A=') ; readln (a) ; write ('B=') ; readln (b) ; write ('C=') ; readln (c) ; if a>0 then pol:=pol+1 else if a=0 then nul:=nul+1 else otr:=otr+1; if b>0 then pol:=pol+1 else if b=0 then nul:=nul+1 else otr:=otr+1; if c>0 then pol:=pol+1 else if c=0 then nul:=nul+1 else otr:=otr+1; writeln ('Положительных: ', pol) ; writeln ('Отрицательных: ', otr) ; writeln ('Нулевых: ', nul) ; end.
  2. 17 декабря, 05:08
    0
    PascalABC

    var x, y, z:real;

    k, m, n:integer;

    begin

    k:=0;

    m:=0;

    n:=0;

    writeln ('Введите первое число') ;

    readln (x) ;

    writeln ('Введите второе число') ;

    readln (y) ;

    writeln ('Введите третье число') ;

    readln (z) ;

    if x>0 then k:=k+1

    else if x=0 then m:=m+1

    else n:=n+1;

    if y>0 then k:=k+1

    else if y=0 then m:=m+1

    else n:=n+1;

    if z>0 then k:=k+1

    else if z=0 then m:=m+1

    else n:=n+1;

    writeln ('Количеcтво положительных чисел : ', k) ;

    writeln ('Количеcтво нулевых чисел : ', m) ;

    writeln ('Количеcтво отрицательных чисел : ', n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу чтоб работала в Pascal запрашивает с клавиатуры три произвольных числа и выводит на экран сообщение о том, сколь - ко из ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как сделать задачу в turbo pascal которая запрашивает с клавиатуры 2 произвольных числа X и Y. Если разность X и Y больше 0, то вычисляет и выводит на экран сумму всех целых чисел от Y до X, иначе вычесляет и выводит на экран разность всех целых
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Написать программу чтоб работала в Pascal запрашивает с клавиатуры два целых числа, их разность и частное (результат деления) и выво дит на экран сообщение о правильности сделанных пользователем вычислений;
Ответы (1)
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
1. Написать программу, которая запрашивает возраст человека, а затем, если возраст меньше 14 лет выводит на экран: "У вас пока нет паспорта", если возраст больше 14 лет выводит на экран: "У вас уже есть паспорт", а если возраст равен 14 годам,
Ответы (1)