Задать вопрос
1 декабря, 11:02

Нужно сделать в Паскале:

Составьте программу, составьте программу, которая вычисляет произведение чисел от 1 до n. Где n вводится с клавиатуры.

+4
Ответы (1)
  1. 1 декабря, 14:03
    0
    Var p, i, n:integer;

    begin

    p:=1;

    writeln ('Введи n') ;

    readln (n) ;

    if n>=1 then

    begin

    for i:=1 to n do

    p:=p*i;

    writeln (p) ;

    end else writeln ('n>=1') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно сделать в Паскале: Составьте программу, составьте программу, которая вычисляет произведение чисел от 1 до n. Где n вводится с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Написать программу, которая вычисляет вычисляет процент от числа. Число и количество процентов вводится с клавиатуры.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)