Задать вопрос
8 сентября, 18:58

Когда мы переписываемся, мы

Когда мы переписываемся, мы часто

используем цифры в нашем тексте. Вам дано одно предложение на английском языке.

Нужно найти все цифры, которые встречаются в этом предложений хотя бы один раз

+5
Ответы (1)
  1. 8 сентября, 21:49
    0
    Много лишнего (наверно), только с олимпиады! Как есть.

    uses crt;

    var b, n, i, k, c, o, x1:integer;

    f, s, ch:string;

    r, g: text;

    A:array [0 ... 9] of integer;

    begin

    assign (r,'C:/Bin. txt') ;

    reset (r) ;

    readln (r, f) ;

    close (r) ;

    for i:=1 to length (f) do

    begin

    s:=copy (f, 1,1) ;

    if (s'0') or (s'1') or (s'2') or (s'3') or (s'4') or (s'5') or (s'6') or (s'7') or (s'8') or (s'9') then

    delete (f, 1,1) ;

    if (s='0') or (s='1') or (s='2') or (s='3') or (s='4') or (s='5') or (s='6') or (s='7') or (s='8') or (s='9') then

    begin

    x1:=pos (s, ch) ;

    if x10 then

    begin

    delete (ch, x1,1) ;

    ch:=ch+s;

    end

    else

    ch:=ch+s;

    end;

    end;

    val (ch, n, o) ;

    N : = Abs (N) ;

    for i : = 0 to 9 do

    A[ i ] : = 0;

    while N > 0 do

    begin Inc (A[ N mod 10]) ;

    N : = N div 10;

    end;

    assign (g,'C:/Bout. txt') ;

    rewrite (g) ;

    for i : = 0 to 9 do

    while A[ i ] > 0 do

    begin Write (g, i) ;

    Dec (A[ i ]) ;

    end;

    close (g) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Когда мы переписываемся, мы Когда мы переписываемся, мы часто используем цифры в нашем тексте. Вам дано одно предложение на английском ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Когда мы переписываемся, мы часто используем цифры в нашем тексте. Вам дано одно предложение на английском языке. Нужно найти все цифры, которые встречаются в этом предложений хотя бы один раз.
Ответы (1)
Дана строка S, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в S ровно один раз. Формат входных данных Во входном файле дана строка S.
Ответы (1)
Дан массив, состоящий из 100 целых чисел: а) Вывести все числа, которые встречаются в этом массиве по нескольку раз; б) Вывести все числа, которые встречаются в массиве только по одному разу.
Ответы (1)
Составим логическое уравнение, которое истинно только тогда, когда хотя бы одно из чисел а в с больше 0. Используем оператор or: (a>0) or (b>0) or (c>0) Помогите составить программу.
Ответы (1)
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)