Задать вопрос
22 мая, 03:49

n factorial это произведение всех чисел от 1 до n. Для заданного числа n определите, сколько нулей в конце десятичной записи n factorial.

+2
Ответы (1)
  1. 22 мая, 06:22
    0
    Program 1;

    var n, k2, k5, i, a:integer;

    begin

    write ('n=') ;

    read (n) ;

    k2:=0; k5:=0;

    for i:=2 to n do begin a:=i;

    if a mod 2=0 then while a>=2 do

    begin

    a:=a div 2;

    k2:=k2+1;

    end;

    a:=i;

    if a mod 5=0 then while a>=5 do begin a:=a div 5;

    k5:=k5+1; end; end;

    if k2
    write (k5) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «n factorial это произведение всех чисел от 1 до n. Для заданного числа n определите, сколько нулей в конце десятичной записи n factorial. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы