Задать вопрос
19 февраля, 22:41

Задача А Четные

N-Factorial - это произведение всех чисел от 1 до N. Для заданного числа N определите, сколько нулей в конце десятичной записи.

Формат входных данных

В единственной строке входного файла содержится одно целое положительно число N (1 N).

Формат выходных данных

Выведите одно целое число-количество нулей в конце десятичной записи N-Factorial.

Имя выходного файла: A. in

Имя выходного файла: А. out

Имя файла решения задачи: A.{c, cpp, pas}

Ограничение по времени: 2 секунды

Ограничение по памяти: 64 мегабайт.

Пример:

A. in A. out Комментарий

4 0 1*2*3*4=24

6 1 1*2*3*4*5*6=720

10 2 1*2*3*4*5*6*7*8*9*10=3628800

+4
Ответы (1)
  1. 20 февраля, 00:46
    -1
    Uses crt;

    var n, mult, i, ans:integer;

    begin

    read (n) ;

    mult:=1;

    for i:=2 to n do

    mult:=mult*i;

    while mult mod 10=0 do begin

    inc (ans) ;

    mult:=mult div 10;

    end;

    writeln (ans) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача А Четные N-Factorial - это произведение всех чисел от 1 до N. Для заданного числа N определите, сколько нулей в конце десятичной ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача W. Сумма двух чисел Имя входного файла: sum. in Имя выходного файла: sum. out Ограничение по времени: 2 секунды Ограничение по памяти: 256 мегабайт Формат входного и выходного файла На первой строке входного файла находятся два целых числа a
Ответы (1)
Имя входного файла: стандартный ввод Имя выходного файла: стандартный вывод Ограничение по времени: 1 секунда Ограничение по памяти: 256 мегабайт У Жарасхана есть массив а из n чисел, к каждому числу массива Жарасхан должен применять лишь одну
Ответы (1)
Имя входного файла:E. in имя выходного файла E. out Дается ... Имя входного файла:E. in имя выходного файла E. out Дается последовательность из N чисел. найдите максимальное произ. среди всех пар этих чисел.
Ответы (1)
Помогитее это на паскале имя входного файла: A. in имя выходного файла: A. out ограничение по времени 2 секунды ограничение по памяти 64 мегабайт пример A. in 13 5 A. out A>B комментарии 13>5
Ответы (1)
Задача D Три числа Дан массив из N целых чисел а1, а2, ..., an. Вам нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю. Формат входных данных В первой строке входного файла содержится одно целое число N (1 ≤ N ≤ 2000).
Ответы (1)