Задать вопрос
7 февраля, 05:36

Организуйте массив. Определите сумму элементов с четными и нечетными индексами.

+1
Ответы (1)
  1. 7 февраля, 05:55
    0
    Program Maas;

    const n=12;

    var a: array[1 ... n] of integer;

    i, sum, sumn: integer;

    begin write ('Массив: ') ;

    for i : = 1 to n do

    begin

    a[i] : = random (10) ;

    write (a[i], ' ') ;

    if i mod 2 = 0 then inc (sum, a[i])

    else inc (sumn, a[i]) ;

    end;

    writeln;

    writeln ('Сумма элементов с четными индексами = ', sum) ;

    writeln ('Сумма элементов с нечетными индексами = ', sumn) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Организуйте массив. Определите сумму элементов с четными и нечетными индексами. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
Составить программу, которая заполняет массив А[1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает. Вывести на экран исходный и полученный массив.
Ответы (1)
Написать программу, которая вводит десять чисел в одномерный массив, а затем определяет среднее арифмитичне элементов с четными индексами и нечетными индексами
Ответы (1)
Составить программу которая выводит массив, где элементы с чётными индексами поменяются местами с нечётными индексами.
Ответы (1)