Задать вопрос
31 июля, 05:51

Дан массив из 10 целых чисел от - 20 до 20.

Написать программу, определяющая каких элементов в нем больше: положительных или отрицательных.

помогите решить, паскаль

+4
Ответы (1)
  1. 31 июля, 08:34
    0
    Program z10;

    var a, b:Array [1 ... 10] of integer;

    i, q, k:integer;

    Begin

    Randomize;

    q:=0; k:=0;

    For i:=1 to 10 do

    begin

    a[i]:=random (40) - 20;

    if (a[i]<0) then q:=q+1;

    if (a[i]>0) then k:=k+1;

    end;

    if (k>q) then writeln ('положительных больше') ;

    if (k
    if (k=q) then writeln ('положительных и отрицательных одинак ... кол-во') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из 10 целых чисел от - 20 до 20. Написать программу, определяющая каких элементов в нем больше: положительных или отрицательных. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)