Задать вопрос
8 апреля, 08:25

Определить, сколько полных часов (h) и полных минут (m) прошло с начала суток до того момента (в первой половине дня), когда часовая стрелка повернется на f градусов (от 0 до 360).

Напишите решение на языке паскаля

+2
Ответы (1)
  1. 8 апреля, 08:50
    0
    Var C: integer;

    h, m: string;

    begin

    readln (C) ;

    C : = C * 2;

    if (C div 60 < 10) then h : = '0' + inttostr (C div 60) ;

    if (C mod 60 < 10) then m : = '0' + inttostr (C mod 60) ;

    writeln (h, ':', m) ;

    end.

    Сам такое недавно делал, только на КуМИР'е)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить, сколько полных часов (h) и полных минут (m) прошло с начала суток до того момента (в первой половине дня), когда часовая ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
написать команды для обмена значениями 2 переменных a и b не используя дополнительную переменную определить сколько полных часов (h) и полных минут (m) прошло с начала суток до того момента (в первой половине дня) когда часовая стрелка повернется на
Ответы (1)
1) Сначала суток прошло n секунд, определить: сколько полных часов прошло с начала суток, сколько полных минут прошло с начала текущего часа, сколько полных секунд прошло сначала текущей минуты.
Ответы (1)
Определить Ч-полное количество часов и М-полное количество минут прошедшего от начала суток до того момента (в первой половине дня) когда часовая стрелка повернулась на А градусов (0
Ответы (1)
Часовая стрелка повернулась с начала суток на d градусов. Вывести, сколько прошло с начала суток полных часов и минут. На вход программе подаётся целое число d от 0 до 360.
Ответы (1)
Идет i-ая секунда суток. Напишите программу, которая по введенной i-ой секунде суток определит, сколько целых часов h, целых минут min и секунд с прошло с начала суток. Например: 13257 секунд = 3 часа 40 минут и 57 секунд.
Ответы (1)