Задать вопрос
4 сентября, 17:03

напишите программу на любом известном Вам алгоритмическом языке. На вход программе подается число N. Далее вводится N чисел. Программа определяет, будет ли произведение этих чисел положительным

+5
Ответы (2)
  1. 4 сентября, 17:41
    0
    Паскаль

    uses crt;

    var n, pr, x:integer;

    a: array [1 ... 1000] of integer;

    begin

    write ('Введи количество чисел последовательности:') ;

    readln (n) ;

    pr:=1;

    for x:=1 to N do

    begin

    readln (a[x]) ;

    pr:=pr*a[x];

    end;

    if pr>0 then writeln ('YES')

    else writeln ('NO') ;

    end.
  2. 4 сентября, 19:22
    0
    Произведение чисел положительно, если среди них есть четное количество отрицательных чисел. И отрицательно, если их нечетное количество.

    Я просто алгоритм напишу

    1) Вводим число N

    2) Устанавливаем счетчик k = 0

    3) Цикл по i от 1 до N

    3.1) Вводим очередное число

    3.2) Если число < 0, то прибавляем счетчик k = k + 1

    3.3) Конец цикла

    4) Если число k четное (k mod 2 = 0), то результат положительный

    Если k нечетное (k mod 2 = 1), то результат отрицательный.

    5) Конец

    А вот делать так, как Sky предлагает, я бы не стал. Он тупо перемножает числа.

    Произведение может оказаться слишком большим, да оно нам и не нужно.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «напишите программу на любом известном Вам алгоритмическом языке. На вход программе подается число N. Далее вводится N чисел. Программа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу на любом известном вам алгоритмическом языке. На вход программе подается число N. Программа формирует N случайных чисел и вычисляет их сумму.
Ответы (1)
Напишите программу на любом вам известном алгоритмическом языке. На вход программе подаётся число N. Программа формирует N случайных чисел сумму тех из них остаток от деления которых на 5 больше двух
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)