Задать вопрос
23 марта, 21:59

Напишите программу на любом известном вам алгоритмическом языке. На вход программе подается число N. Программа формирует N случайных чисел и вычисляет их сумму.

+3
Ответы (1)
  1. 24 марта, 00:02
    0
    Ну так как знаю язык программы Dev-C++, напишу ... и если я не ошибаюсь это массив : -)

    #include

    main ()

    {

    int i, n;

    float s;

    printf ("n=") ;

    scanf ("%d", &n) ;

    int a[n];

    for (i=0; i {

    printf ("/n a[%d]=", i) ;

    scanf ("%d", &a[i]) ;

    }

    s=0;

    for (i=0; i s=s+a[i];

    printf ("s=%f", s) ;

    puts ("Massiv:") ;

    for (i=0; i printf ("/n a[%d]=%d", i, a[i]) ;

    getchar () ;

    return (0) ;

    }

    напишу краткое объяснение, 1 - пишем н, произвольное, это количемтво этих исел будет,

    2 - создаем массив с и (параметр массива) меньшим н ... там мы пишем эти числа, сумму которых нужно всчитать

    3 - находим сумму

    4 - пишем чемк она равна

    5 - выводим массив

    и все

    если программа не бкдет идти напиши вконце место return (0) ; = > getchar () ;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на любом известном вам алгоритмическом языке. На вход программе подается число N. Программа формирует N случайных чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу на любом вам известном алгоритмическом языке. На вход программе подаётся число N. Программа формирует N случайных чисел сумму тех из них остаток от деления которых на 5 больше двух
Ответы (1)
напишите программу на любом известном Вам алгоритмическом языке. На вход программе подается число N. Далее вводится N чисел. Программа определяет, будет ли произведение этих чисел положительным
Ответы (2)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет: а) среднее арифметическое нечётных чисел б) сумму чисел, не превышающих 10 в) сумму чисел кратных 3 На экран выводятся исходные значения и результаты
Ответы (1)