Задать вопрос
26 декабря, 13:48

Дан массив вещественных чисел. Каждый отрицательный элемент заменить на его абсолютную величину

+4
Ответы (1)
  1. 26 декабря, 15:47
    0
    Uses crt;

    var i, n:integer;

    a:array[1 ... 100] of real;

    begin

    writeln ('Сколько чисел в массиве?') ;

    read (n) ;

    writeln ('Введите элементы.') ;

    for i:=1 to n do

    begin

    read (a[i]) ;

    if a[i]<0 then

    a[i]:=abs (a[i]) ;

    end;

    for i:=1 to n do

    write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив вещественных чисел. Каждый отрицательный элемент заменить на его абсолютную величину ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделайте в паскаль. Дан массив вещественных чисел. Вывести на экран новое состояние массива, в котором: a) Каждый отрицательный элемент заменить на его абсолютную величину; b) Все элементы с нечетными номерами заменить на их квадратный корень;
Ответы (1)
Дан массив вещественных чисел x[8]. Каждый отрицательный элемент заменить на его абсолютную величину.
Ответы (1)
Ввести массив F (n) вещественных чисел. Если последний элемент массива положительный, то найти max среди элементов массива и заменить его значений последний элемент массива. Массив распечатать. Иначе - дать сообщение "Массив остался без изменений"
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)