Задать вопрос
9 октября, 13:39

Ввести массив F (n) вещественных

чисел. Если последний элемент массива положительный, то найти max среди

элементов массива и заменить его значений последний элемент массива. Массив

распечатать. Иначе - дать сообщение "Массив остался без изменений"

+3
Ответы (1)
  1. 9 октября, 17:36
    0
    Program Zadacha;

    Const n = 5;

    Var a: Array[1 ... n] Of Real;

    i, j: Integer;

    Begin

    WriteLn ('Введите ', n, ' чисел через пробел') ;

    For i : = 1 To n DoRead (a[i]) ;

    If a[n] > = 0 ThenBeginj : = 1;

    For i : = 1 To n Do

    If a[i] > a[j] Then

    j : = i; a[n] : = a[j];

    For i : = 1 To n Do

    Write (a[i], ' ') ;

    End

    Else

    WriteLn ('Массив остался без изменений') ;

    ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести массив F (n) вещественных чисел. Если последний элемент массива положительный, то найти max среди элементов массива и заменить его ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Помогите переделать код на C# Дан одномерный массив из n элементов. Требуется найти максимальный элемент и отклонение от максимального для каждого из элементов. (Ввод элементов с клавиатуры) var a:array[1 ...
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Где ошибка? Sub сер Dim x, y, z, f, max, min As Single x = Val (InputBox (2)) y = (InputBox (6)) z = (InputBox (10)) If x / 2 > y / 3 > z / 4 Then If x / 2 > y / 3 Then max = x / 2 Else max = y / 3 End If End If Else If y / 3 > z / 4 Then max =
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)