Задать вопрос
5 октября, 12:00

Ребята, кто разбирается в программировании, помогите!

Составьте программу, вычисляющую, сколько процентов от А+В-С приходится: а) на А б) на Б в) на В

+1
Ответы (1)
  1. 5 октября, 12:23
    0
    Program s;

    uses crt;

    var

    a, b, c, d, pa, pb, pc:real;

    begin

    writeln ('Введите А: ') ;

    read (a) ;

    writeln ('Введите В: ') ;

    read (b) ;

    writeln ('Введите C: ') ;

    read (c) ;

    d:=a+b+c;

    pa: = (a/d) * 100;

    pb: = (b/d) * 100;

    pc: = (c/d) * 100;

    writeln ('На А приходиться ', pa:2:2,' на В ', pb:2:2,' на С ', pc:2:2) ; / / значание округлены до 2 знаков

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ребята, кто разбирается в программировании, помогите! Составьте программу, вычисляющую, сколько процентов от А+В-С приходится: а) на А б) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
1. написать программу, вычисляющую значение функции y=x-24 2. написать программу, вычисляющую значение функции (y=f (x)) y=x-2, если x>0, y=0, если x=0, y=x*x, если x
Ответы (1)
Напишите функцию, вычисляющую длину отрезка по координатам его концов. С помощью этой функции напишите программу на Pascal ABC, вычисляющую периметр треугольника по координатам его вершин
Ответы (1)