Задать вопрос
5 июня, 20:44

Написать программу на паскале, Вычесление суммы цыфр натурального числа N

+4
Ответы (1)
  1. 5 июня, 21:26
    0
    Var

    n, s: integer;

    begin

    read (n) ;

    while n > 0 do

    begin

    s : = s + n mod 10;

    n : = n div 10;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на паскале, Вычесление суммы цыфр натурального числа N ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача по информатике. число с трёх разных цыфр отняли от числа, что складываеться с тех самых цыфр, расположеных в обратном порядке. результат складываеться из тех самых трёх цыфр, расположеных по-другому. найди эти числа.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
определите полный набор данных для решения следующих задач обработки информации 1) Вычесление площади прямоугольника 2) Приготовление обеда 3) Вычесление стоимости покупок в магазине 4) Приготовлени салата по рецепту 5) Выполнение домашнего задания
Ответы (1)
Зачетная работа по информатике. 1. Написать программу вычисления площади прямоугольника (на паскале). 2. Написать программу вычесления ускорения тела (на паскале).
Ответы (1)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)