Задать вопрос
5 июня, 20:44

Pascal!

Дан массив целых чисел. Проверить, есть ли в нем одинаковые элементы.

+5
Ответы (1)
  1. 5 июня, 23:00
    0
    Var a: array[1 ... 10] of integer;

    var i, j, ans:integer;

    begin

    ans:=0;

    for i:=1 to 10 do

    begin readln (a[i]) ;

    end;

    for i:=1 to 10 do

    begin

    for j:=i+1 to 10 do

    begin

    if a[i]=a[j] then ans:=ans+1;

    end;

    end;

    if ans>0 then writeln ('есть')

    else writeln ('нет') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal! Дан массив целых чисел. Проверить, есть ли в нем одинаковые элементы. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив целых чисел из 12 элементов. Напечатать все четные элементы. 2) Дан массив целых чисел из 10 элементов. Все элементы, кратные числу 10, заменить нулём. Нужна полная программа, Pascal ABC.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)