Задать вопрос
15 декабря, 18:44

Цикл с пост условием! помогите

Написать программу которая будет вводить целые числа до тех пор пока не будетвведён 0. Подсчитать количество положительных и отрицательных чисел.

+5
Ответы (1)
  1. 15 декабря, 21:06
    0
    Var N, otr, pol:real; Begin Read (n) ; If n=0 writeln ('error') else Repeat do Write (n) ; If n mod 2=0 then pol:=pol+1 else otr:=otr+1; Read (n) ; Until n=0; Writeln ('otr:', otr) ; Writeln ('otr:', otr) ; End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Цикл с пост условием! помогите Написать программу которая будет вводить целые числа до тех пор пока не будетвведён 0. Подсчитать количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить две программы на языке Паскаля с помощью операторов цикла До и Пока, которые будут вводить целые числа (до тех пор, пока не будет введен ноль), подсчитывать сумму и среднее арифметическое введеных положительных чисел.
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчитать количество введённых положительных и отрицательных чисел.
Ответы (1)
Программу которая будет вводить целые числа до тех пор пока не будет введен нуль и определение
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Составить программу, которая запрашивает числа и считает количество введенных отрицательных чисел, до тех пор, пока пользователь не введет 0. Использовать цикл с предусловием. На обычном паскале, не турбо.
Ответы (1)