Задать вопрос
23 января, 14:44

Дан массив. Упорядоченный по возрастанию и число b неравное ни одному из этих элементов. Найти элемент массива ближайший к b.

+2
Ответы (1)
  1. 23 января, 14:58
    0
    Var a:array[1 ... 10] of integer;

    i, b, ind, el, min:integer;

    begin

    min:=1000000;

    for i:=1 to 10 do

    read (a[i]) ;

    readln;

    read (b) ;

    for i:=1 to 10 do begin

    if abs (a[i]-b)
    min:=abs (a[i]-b) ;

    el:=a[i];

    ind:=i;

    end;

    end;

    write (el,' ', ind) ; / / Выводит элемент, а затем его индекс.

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив. Упорядоченный по возрастанию и число b неравное ни одному из этих элементов. Найти элемент массива ближайший к b. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Паскаль! Дан массив А размерностью N. Записать в каждый элемент массива В следующие значения: 1 ый элемент - сумма всех нечетных элементов массива А; 2 ои элемент - сумма всех четных элементов массива А: Зий элемент - сумма всех элементов массива А
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)