Задать вопрос
24 сентября, 00:20

Дан массив состоящий из 10 целых чисел, заданных случайным образом из промежутка [5 ... 25] найти минимальное и максимальное значения, их сумму

+4
Ответы (1)
  1. 24 сентября, 04:11
    0
    uses crt;

    const N=10;

    var a:array [1 ... N] of integer;

    x, min, max, sum:integer;

    begin

    randomize;

    for x:=1 to N do

    begin

    a[x]:=random (21) + 5;

    writeln ('a[', x,']:', a[x]:3) ;

    end;

    min:=a[1];

    max:=a[1];

    for x:=1 to N do

    begin

    if a[x]
    if a[x]>max then max:=a[x];

    end;

    sum:=min+max;

    writeln;

    write ('max:', max,'; min:', min,'; max+min=', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив состоящий из 10 целых чисел, заданных случайным образом из промежутка [5 ... 25] найти минимальное и максимальное значения, их ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1. Даны два целых числа A и B (A < B). Найти сумму всех чисел от A до B включительно. 2. Даны два целых числа A и B (A 0). Найти произведение всех чисел от A до B включительно. 3. Дан массив целых чисел Х. Найти сумму квадратов всех чисел. 4.
Ответы (1)