Задать вопрос
24 сентября, 00:45

Помогите по информатике!

Дана последовательность целых чисел, 0 - конец последовательности. Определите, сколько раз в последовательности меняется знак.

+3
Ответы (1)
  1. 24 сентября, 01:34
    0
    Var n, i, n1: integer;

    begin

    read (n) ;

    i : = 0;

    n1 : = 0;

    while n 0 do

    begin

    if n1 * n < 0 then

    i : = i + 1;

    n1 : = n;

    read (n) ;

    end;

    writeln (i) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите по информатике! Дана последовательность целых чисел, 0 - конец последовательности. Определите, сколько раз в последовательности ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Вводится последовательность целых ненулевых чисел, 0 - конец последовательности. Определить, сколько раз последовательность поменяет знак. Ограничения! Нельзя использовать условный оператор (If) и оператор выбора (Case).
Ответы (1)
Дана последовательность целых чисел. Прищнак окончания ввода - число 0 (элементом последовательности не считается). В последовательности как минимум одно число. Написать программу, определяющую, является ли последовательность чисел возрастающей.
Ответы (1)
Дана последовательность целых чисел. Получить упорядоченную по невозрастанию последовательность, состоящую из членов данной последовательности, заключённых между первым и последним отрицательными членами данной последовательности.
Ответы (1)
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)