Задать вопрос
1 августа, 17:13

1. Дано натуральное число n. Найти все меньшие n простые числа, которые могут быть представлены в виде 2 ^p - 1, где p - тоже простое число. (ABC Pascal)

+4
Ответы (1)
  1. 1 августа, 20:21
    0
    Uses

    System. Collections. Generic,

    System;

    var

    simple: List : = new List;

    i, n, p: integer;

    m: longint;

    begin

    read (n) ;

    for i : = 2 to n do

    begin

    m : = 1;

    foreach s: integer in simple do

    m : = m * i mod s;

    if m > 0 then begin

    simple. Add (i) ;

    / / write (i, ' ') ;

    end;

    end;

    writeln () ;

    foreach s: integer in simple do

    begin

    if Math. Pow (2, s) - 1 < = longint. MaxValue then begin

    m : = round (Math. Pow (2, s) - 1) ;

    if (m < = n) and simple. Contains (m) then

    write (m, ' ') ;

    end;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дано натуральное число n. Найти все меньшие n простые числа, которые могут быть представлены в виде 2 ^p - 1, где p - тоже простое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Операция "логическое и" применяется в сложных условиях, когда 1 все простые условия должны быть истинными 2 все простые условия должны быть ложными 3 хотя бы одно простое условия должно быть ложным 4 хотя бы одно простое условия должно быть истинным
Ответы (1)