Задать вопрос
5 марта, 11:19

Язык "Паскаль АВС" найти произведение всех двузначных чисел, сумма цифр которых равна 8

+5
Ответы (1)
  1. 5 марта, 11:58
    0
    Var i, s, a:integer;

    Begin

    a:=1;

    for i:=10 to 99 do

    Begin

    s:=i mod 10 + i div 10;

    if s=8 then a:=a*i;

    end;

    writeln (a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Язык "Паскаль АВС" найти произведение всех двузначных чисел, сумма цифр которых равна 8 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задачи: 1) Найти насколько (количество) двузначных чисел кратных 3 больше чем двузначных чисел кратных 5.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Найдите и выведите на экран все двузначные числа, сумма цифр которыx не меняется при умножении на 2. (например, 27 и 27*2=54, сумма цифр чисел 27 и 54 равна 9) Язык программирования паскаль АВС
Ответы (1)
Автомат получает на вход два двузначных десятичных числа. По полученным числам строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма цифр первого числа и сумма цифр второго числа. 2.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)