Задать вопрос
26 октября, 22:57

Написать программу в паскаль ABC. Теорема Ферма утверждает, что не существует решения в целых числах уравнения x^n+y^n=z^n при n>2.

напишите программу, которая проверяла бы это утверждение при заданном n для всех x, y и z меньших 100.

+3
Ответы (1)
  1. 27 октября, 02:10
    0
    Если n небольшие, то можно написать так:

    var

    x, y, z, n: integer;

    disproved: boolean;

    begin

    write ('Введите n: ') ;

    readln (n) ;

    disproved : = false;

    for x : = 1 to 100 do

    for y : = 1 to 100 do

    for z : = 1 to 100 do

    if power (x, n) + power (y, n) = power (z, n) then

    begin

    writeln ('Ферма ошибся! ', x, ' ^ ', n, ' + ', y, ' ^ ', n, ' = ', z, ' ^ ', n) ;

    disproved : = true;

    end;

    if not disproved then

    writeln ('Теорема не опровергнута') ;

    end.

    При больших n уже придётся использовать длинную арифметику.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в паскаль ABC. Теорема Ферма утверждает, что не существует решения в целых числах уравнения x^n+y^n=z^n при n>2. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Написать программу для решения уравнения AX2 + BX+C=0. (Дописать до конца) 2) Написать программу для решения неравенства Bx+C
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)