Задать вопрос
17 июня, 23:58

Составить программу для нахождения корней квадратного уравнения ах2+вх+с

+4
Ответы (1)
  1. 18 июня, 03:49
    0
    Uses crt;

    var

    d, a, b, c, x1, x2: real;

    begin

    writeln ('Введите a, b, c') ;

    readln (a, b, c) ;

    d : = b * b - 4 * a * c;

    if d > 0 then

    begin

    x1 : = (-b + sqrt (d)) / (2 * a) ;

    x2 : = (-b - sqrt (d)) / (2 * a) ;

    writeln ('x1 = ', x1:2:2) ;

    writeln ('x2 = ', x2:2:2) ;

    end

    else if d = 0 then

    begin

    x1 : = - b / (2 * a) ;

    writeln ('x = ', x1:2:2) ;

    end

    else

    writeln ('Нет действительных корней') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу для нахождения корней квадратного уравнения ах2+вх+с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы