Задать вопрос
17 марта, 13:44

По заданному возрасту человека (n целое число) вывести сообщение каков возраст, добавляя к n слова "лет", "год" или "года". Например, 25 лет, 4 года, 51 год.

+1
Ответы (1)
  1. 17 марта, 14:44
    0
    Var

    n:integer;

    s:string;

    begin

    readln (n) ;

    case n mod 10 of

    1:s:=' год';

    2 ... 4:s:=' года';

    0,5 ... 9:s:=' лет';

    end;

    case n mod 100 of

    11 ... 19:s:=' лет';

    end;

    writeln (n, s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «По заданному возрасту человека (n целое число) вывести сообщение каков возраст, добавляя к n слова "лет", "год" или "года". Например, 25 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Помогите написать программу в python Уровень C. Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год", "года" или "лет". Например, "21 год", "22 года", "25 лет".
Ответы (2)
Используя условный оператор if написать конструкцию которая проверяет возраст и выводит соответствующие значения по такому словию: Если возраст больше либо равен 18 - вывести сообщение "ok" иначе если возраст больше 14 - вывести сообщение "with
Ответы (1)
напишите программу, которая вводит возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год", "года" или "лет". например: 21 год, 22 года, 25 лет
Ответы (1)
Помогите составить программу) Введите исходные данные: Возраст Коли: 12 Возраст Миши: 17 Средний возраст: 14.5 лет Возраст Колт отличается от среднего возраста на: - 2.5 лет Возраст Миши отличается от среднего возраста на: 2.5 лет
Ответы (1)