Задать вопрос
13 октября, 16:46

Составить программу, которая по введенному натуральному числу n вычисляет произведение четных чисел из диапазона от 1 до n. (паскаль)

+3
Ответы (1)
  1. 13 октября, 17:45
    0
    Var n, s, i:integer;

    begin

    s:=1;

    writeln ('Введите число') ;

    readln (n) ;

    for i:=1 to n do

    begin

    if (i mod 2 = 0) then s:=s*i;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая по введенному натуральному числу n вычисляет произведение четных чисел из диапазона от 1 до n. (паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программисту поставили задачу написать программу, которая по введённому натуральному числу n должна выводить через пробел все нечётные числа из диапазона от 1 до n.
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Програмисту поставили задачу написать программу которая по введённому натуральному числу n должна выводить через пробел все нечетные числа из диапазона от 1 до n
Ответы (1)
1) составить программу, которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный 2-ая Составить программу, которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми язык паскаль
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)