Задать вопрос
5 января, 00:37

Даны числа АВС, четные числа умножить на 2, к нечетным прибавить 3. Решить про помощи Паскаля

+4
Ответы (1)
  1. 5 января, 00:44
    0
    Program ten;

    Var A, B, C: integer;

    Begin

    Write ('Введите число A ') ; Read (A) ;

    Write ('Введите число B ') ; Read (B) ;

    Write ('Введите число C ') ; Read (C) ;

    If A mod 2 = 0 Then A:=A*2 Else A:=A+3;

    If B mod 2 = 0 Then B:=B*2 Else B:=B+3;

    If C mod 2 = 0 Then C:=C*2 Else C:=C+3;

    Write (' число A', A) ;

    Write (' число B', B) ;

    Write (' число C', C) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны числа АВС, четные числа умножить на 2, к нечетным прибавить 3. Решить про помощи Паскаля ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. (x делится без остатка на 2 и на 3) записать на языке паскаля. 2. (х не делится на 5) записать на языке паскаля. 3. (величина х не кратна 3) записать на языке паскаля.
Ответы (1)
Составьте программу в АВС Паскаль. Даны два указанных с клавиатуры числа 3 и 6. Нужно выполнить следующее: чётные числа умножить на 3, нечётные поделить на 4 (числа от 3 до 6) и вывести в виде;
Ответы (1)
Выполнить алгоритм: 1) Найти сумму чисел 1 и 3; 2) Прибавить к полученной сумме число 5; 3) Прибавить к полученной сумме число 7; 4) Прибавить к полученной сумме число 9; 5) Прибавить к полученной сумме число 11; 6) Сообщить результат.
Ответы (2)
Выполните алгоритм 1) Найти сумму чисел 1 и 3. 2) Прибавить к полученной сумме число 5. 3) Прибавить к полученной сумме число 7. 4) Прибавить к полученной сумме число 9. 5) Прибавить к полученной сумме число 11. 6) Напечатай результат.
Ответы (2)
С помощью оператора Паскаля FOR Вывести на экран: 1) все четные числа из диапазона от A до B, кратные трем (A 2) все двузначные числа, в которых старшая цифра отличается от младшей не больше чем на 1;
Ответы (1)