Задать вопрос
19 марта, 17:21

Написать программу на Pascal ABC. Дано

предложение. Вывести строку в обратном порядке. Вывести столбиком все его буквы

"и", стоящие на четных местах.

+1
Ответы (1)
  1. 19 марта, 19:50
    0
    Var

    str : string;

    i, count : integer;

    begin

    {часть 1 - обратный порядок}

    write ('Введите строку: ') ;

    readln (str) ;

    write ('Результат: ') ;

    for i : = length (str) downto 1 do

    write (str[i]) ;

    {часть 2 - считаем "и"}

    count : = 0;

    for i : = 1 to length (str) do

    if (str[i] = 'и') and (i mod 2 = 0) then

    count : = count + 1;

    writeln; {переходим на следующую строку}

    for i : = 1 to count do

    writeln ('и') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Pascal ABC. Дано предложение. Вывести строку в обратном порядке. Вывести столбиком все его буквы "и", стоящие на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу: 1) сформировать массив из 18 целых случайных чисел из [-35; 35], вывести исходный массив в строку; 2) найти среднее арифметическое всех четных элементов массива; 3) найти сумму неотрицательных элементов;
Ответы (1)
Дан одновременный одночисленный масив вывести масив на экран строку элементы стоящие на четных местах заменить нулем вывести образованный массива на экран строку пример: ввод: 5; 5,1,2,3,4 вывод: 5,0,2,0,4
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
В виде программ: 1 Заполнить массив N числами (N
Ответы (1)
Дан массив А (20). Переписать элементы этого массива, стоящие на четных местах, подряд в массив В, а стоящие на нечетных местах - в массив С. Все три массива отпечатать. (сложнА, знаю) хыхыхы
Ответы (1)