Задать вопрос
22 февраля, 13:45

Дан одновременный одночисленный масив вывести масив на экран строку элементы стоящие на четных местах заменить нулем вывести образованный массива на экран строку пример:

ввод: 5; 5,1,2,3,4

вывод: 5,0,2,0,4

+1
Ответы (1)
  1. 22 февраля, 17:19
    0
    Program chik;

    var a:array[1 ... 1000]of integer;

    var n, i:integer;

    begin

    read (n) ;

    for i:=1 to n do

    begin

    read (a[i]) ;

    end;

    for i:=1 to n do

    begin

    if (i mod 2=0) then a[i]:=0;

    end;

    for i:=1 to n do

    begin

    write (a[i],' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан одновременный одночисленный масив вывести масив на экран строку элементы стоящие на четных местах заменить нулем вывести образованный ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан одновременный массив, состоящий из 10 эллементов. Пользователь вводит элементы массива. Ввести массив на экран в строку. Найти минимальный элемент массива.
Ответы (1)
Напишите программу, которая фармирует масси из N элементов (максимальное количество элементов равно 20), значения элементов массива - случайные числа от - 10 до 25 Программа должна: 1) выводить на экран сначала все элементы массива, стоящие на
Ответы (1)
Дан массив А (20). Переписать элементы этого массива, стоящие на четных местах, подряд в массив В, а стоящие на нечетных местах - в массив С. Все три массива отпечатать. (сложнА, знаю) хыхыхы
Ответы (1)
Даны два целочисленных массива. Найти сумму элементов первого массива, стоящих на четных местах, и заменить ею все элементы второго массива, стоящие на нечетных местах (в паскаль)
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)