Задать вопрос
16 августа, 10:12

Паскаль написать прогу. анна и борис играют в игру загадай число. оба игрока записывают на бумаге число от 1 до 6. затем бросают кубик, н7 а гранях которого нарисованны точки в соответствии 1 2 3 4 5 6. выигрывает тот игрок, чье число оказывается ближе к точке, выпавшей на кубике. если анна загадала 3, борис загадас 6, а выпало 4 анна выиграла. если анна загадала 2 борис 4 выпало 3 невыиграл никто. сколько раз выиграл каждый из них.

+3
Ответы (1)
  1. 16 августа, 13:36
    0
    Вот, сначала ввести числа Анны и Бориса, а потом кол-во бросков =)

    var x, a, b, k, i, wa, wb: integer;

    begin

    readln (a, b) ;

    readln (k) ;

    for i : = 1 to k do

    begin

    x : = random (5) + 1;

    writeln (x) ;

    if ((abs (a - x) > abs (b - x))) then wa : = wa + 1;

    if ((abs (a - x) < abs (b - x))) then wb : = wb + 1;

    end;

    if (wa > wb) then writeln ('Ann win!')

    else

    if (wb > wa) then writeln ('Boris win!')

    else

    writeln ('No win;) ') ;

    writeln (wa, ' - ', wb) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль написать прогу. анна и борис играют в игру загадай число. оба игрока записывают на бумаге число от 1 до 6. затем бросают кубик, н7 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Два игрока играют в следующую игру. перед ними лежат три кучки камней, в первый 2 камня, во второй - 3, в третьей - 4. у каждого игрока неограниченное кол-во камней. игроки ходят по очереди.
Ответы (1)
Два игрока играют в следующую игру. перед ними лежат три кучки камней, в первый 3 камня, во второй - 1. у каждого игрока неограниченное кол-во камней. игроки ходят по очереди.
Ответы (1)
Двое играют в следующую игру. Из кучки спичек за один ход игрок вытягивает либо 1, либо 2, либо 1000 спичек. Выигрывает тот, кто забирает последнюю спичку.
Ответы (1)
Два игрока играют в следующую игру. На координатной плоскости стоит фишка. Игроки ходят по очереди. В начале фишка находится в точке с координатами (-2; 1).
Ответы (1)
Два игрока играют в игру. На координатной плоскости стоит фишка. Игроки ходят поочереди. В начале игры фишка находится в точке с координатами (4,2).
Ответы (1)