Задать вопрос
1 августа, 14:35

Даны два целочисленных массива. Найти сумму элементов первого массива, стоящих на четных местах, и заменить ею все элементы второго массива, стоящие на

нечетных местах (в паскаль)

+4
Ответы (1)
  1. 1 августа, 17:36
    0
    Program p1;

    const n = 10;

    var a: array[1 ... n] of integer; b: array[1 ... n] of integer; i, sum, j: integer;

    begin

    for i : = 1 to n do begin a[i] : = random (10) ; write (a[i], ' ') end; writeln;

    for i : = 1 to n do begin b[i] : = random (10) ; write (b[i], ' ') end; writeln;

    sum : = 0;

    for i : = 1 to n do if i mod 2 = 0 then sum : = sum + a[i];

    for i : = 1 to n do if i mod 2 0 then b[i] : = sum;

    for i : = 1 to n do write (b[i], ' ')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны два целочисленных массива. Найти сумму элементов первого массива, стоящих на четных местах, и заменить ею все элементы второго ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Имеется целочисленный массив состоящий из N элементов (N - чётное) а) Найти сумму первых N/2 элементов. б) Найти сумму элементов стоящих на чётных позициях. в) Найти произведение элементов стоящих на нечётных позициях.
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
Паскаль, помогите! В числовом массиве из 10 элементов, заданных случайным образом от - 100 до 500. Найти: 1) сумму положительных элементов, стоящих на чётных местах; 2) произведение элементов массива, кратных 3 и стоящих на нечётных местах;
Ответы (1)
Напишите программу, которая фармирует масси из N элементов (максимальное количество элементов равно 20), значения элементов массива - случайные числа от - 10 до 25 Программа должна: 1) выводить на экран сначала все элементы массива, стоящие на
Ответы (1)
В одномерном массиве, состоящем из n элементов, вычислить: 1) количество отрицательных элементов массива, расположенных на четных местах 2) сумму четных элементов массива, расположенных на нечетных местах.
Ответы (1)