Задать вопрос
8 октября, 08:54

Составить блок схему и написать

программу, которая находит сумму нечетных и количество четных делителей натурального числа. (31954)

+4
Ответы (1)
  1. 8 октября, 09:28
    0
    Var n, i, k, s:integer;

    begin

    read (n) ;

    k:=0;

    s:=0;

    for i:=1 to n do

    begin

    if (n mod i = 0) then

    begin

    if (i mod 2 = 0) then

    begin

    k:=k+1;

    end else

    begin

    s:=s+i;

    end;

    end;

    end;

    writeln ('Кол-во чётных - ', k) ;

    writeln ('Сумма нечётных - ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить блок схему и написать программу, которая находит сумму нечетных и количество четных делителей натурального числа. (31954) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Дано некоторое целое число. Написать программу, которая определяет, каких цифр в нем больше четных или нечетных. Кроме того, сформировать из данного числа два новых числа. Первое должно состоять из нечетных цифр исходного числа, а второе из четных.
Ответы (1)
Написать программу, которая для первых n натуральных чисел находит сумму чётных и произведение нечётных чисел. число n вводится с клавиатуры. выполнить программу для n=13, записать результат
Ответы (1)
Написать программу, которая выведет 4 первые четных числа (2,4,6,8) и написать программу которая находит сумму этих чисел.
Ответы (1)
Написать программу которая минимальное значение четных и не четных в заданном диапазоне и сумму и среднее ариф. Всех и четных и нечетных. python3 через цикл while
Ответы (1)