Задать вопрос
12 апреля, 02:16

Написать программу, которая для первых n натуральных чисел находит сумму чётных и произведение нечётных чисел. число n вводится с клавиатуры. выполнить программу для n=13, записать результат

+1
Ответы (1)
  1. 12 апреля, 03:44
    0
    Const n=13;

    var i, s, p:integer;

    begin

    s:=0; p:=1;

    for i:=1 to n do begin

    if (i mod 2 = 0) then s:=s+i;

    if (i mod 2 0) then p:=p*i;

    end;

    writeln ("Сумма четных = ", s,", произведение нечетных = ", p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая для первых n натуральных чисел находит сумму чётных и произведение нечётных чисел. число n вводится с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу которая находит сумму чисел которые делятся на 3, для первых n натуральных чисел. число n вводится с клавиатуры. выполнить программу для n=50 записать результат.
Ответы (1)
Написать программу которая находит произведение n первых натуральных чисел. число n вводится с клавиатуры. выполнить программу для n=9 записать результат.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)