Задать вопрос
12 марта, 23:03

напишите программу вычисляющую значение функции y=1 при x<0, y=0 при x=0, y=-1 при x<0

+2
Ответы (1)
  1. 13 марта, 00:58
    0
    В условии опечатка: два раза написано x < 0.

    1) Если функция имеет вид y = 1 при x > 0, 0 при x = 0, - 1 при x < 0:

    var

    x: real;

    y: integer;

    begin

    readln (x) ;

    if x > 0 then

    y : = 1

    else if x = 0 then

    y : = 0

    else

    y : = - 1;

    writeln (y)

    end.

    2) Если функция имеет вид y = 1 при x 0, надо просто поменять местами 1 и - 1 в решении выше.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «напишите программу вычисляющую значение функции y=1 при x ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. написать программу, вычисляющую значение функции y=x-24 2. написать программу, вычисляющую значение функции (y=f (x)) y=x-2, если x>0, y=0, если x=0, y=x*x, если x
Ответы (1)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
Напишите функцию, вычисляющую длину отрезка по координатам его концов. С помощью этой функции напишите программу на Pascal ABC, вычисляющую периметр треугольника по координатам его вершин
Ответы (1)