Задать вопрос
11 октября, 10:48

Составить программу, выводящую количество корней квадратного уравнения

+5
Ответы (2)
  1. 11 октября, 11:24
    0
    Var

    a, b, c:integer;

    q:real;

    Begin

    Writeln ('a*x^2+b*x+c') ;

    Write ('Введите A: ') ; readln (a) ;

    Write ('Введите B: ') ; readln (b) ;

    Write ('Введите C: ') ; readln (c) ;

    q:=b*b-4*a*c;

    if q>0 then writeln ('2 корня') ;

    if q=0 then writeln ('1 корень') ;

    if q<0 then writeln ('0 корней') ;

    End.
  2. 11 октября, 12:47
    0
    Var a, b, c:integer; q:real; beginwriteln ('a*x^2+b*x+c') ; writeln ('vvedite a') ; readln (a) ; writeln ('vvedite b') ; readln (b) ; writeln ('vvedite C') ; readln (c) ; q:=b*b-4*a*c; If q>0 then writeln (2) ; If q=0 then writeln (1) ; If q<0 then writeln (0) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, выводящую количество корней квадратного уравнения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Составить программу удаляющую из данного текста все буквосочетания "ма" и выводящую получившийся текст и его длину. 2) Составить программу находящую количество букв "с" в тексте.
Ответы (1)
Помогите составить программу с помощью цикла repeat. составить программу выводящую и суммирующую любое количество целых чисел если введено 999 о на экран выводится результат суммирования.
Ответы (1)
1) даны 3 числа a, b, c, являющиеся коэффициентами квадратного уравнения. Составить алгоритм и программу для нахождения корней этого квадратного уравнения.
Ответы (1)
Задание 1. составьте программу вычисления количества двузначных чисел, которые кратны 2 и 3. задание 2. составьте программу, выводящую на экран все двузначные числа, у которых первая цифра в два раза больше второй. задание 3.
Ответы (1)
1. Написать программу, выводящую на экран строку "Hello World" 10 раз. 11. Написать программу, которая выводит на экран линию из символов.
Ответы (1)