Задать вопрос
19 апреля, 07:09

Необходимо оклеить обоями комнату с заданными величинами длины и высоты стен. также заданы длина, ширина и цена одного рулона обоев. подсчитать суммарные расходы в денежном выражении.

+2
Ответы (1)
  1. 19 апреля, 07:14
    0
    Var a, b, c, m, l, s1, s, k:real;

    begin

    write ('Длина, ширина и высота комнаты: ') ;

    readln (a, b, c) ;

    write ('Длина, ширина и цена одного рулона: ') ;

    readln (l, m, s1) ;

    k:=2 * (a+b) * c/m/l;

    if k-int (k) >0 then k:=k+1;

    k:=int (k) ;

    s:=s1*k;

    writeln ('Потребуется рулонов: ', k) ;

    writeln ('Стоимость покупки: ', s)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Необходимо оклеить обоями комнату с заданными величинами длины и высоты стен. также заданы длина, ширина и цена одного рулона обоев. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите составить алгоритм: Требуется рассчитать необходимое кол-во рулонов обоев для оклейки комнаты. Заданы параметры комнаты а, b, h. Заданы параметры рулонов обоев длина l, ширина-d, считаем что S окон и дверей составляет 15 % от площади стен.
Ответы (1)
Составьте программу в паскале со всеми строчками! Хозяин хочет оклеить обоями длинную стену в своем доме. Длина этой стены равна А метров, а высота - В метров. Рулон обоев имеет длину 12 метров и ширину K см.
Ответы (1)
Требуется оклеить обоями стены комнаты, длина которой 5 м, ширина - 3 м, а высота - 2,8 м. Хватит ли 8 рулонов обоев размером 10 м на 0,5 м для оклейки комнаты, если отходы не превосходят 5%, а окна и двери составляют 25% общей площади стен комнаты.
Ответы (1)
Написать прогу в паскале. Нужно высчитать минимальные затраты на поклейку обоями комнаты. 3 вида обоев (по ширине),3 вида обоев (3 типа обоев) + разные цены на обои, 1 вид клея, из площади комнаты вычесть площадь окон и дверей.
Ответы (1)
Оклеить все стены комнаты обоями. Комната прямоугольная, в которой n штук дверей и m штук окон. Сколько рулонов обоев потребуется?
Ответы (1)