Задать вопрос
3 августа, 10:13

Составьте программу в паскале со всеми строчками! Хозяин хочет оклеить обоями длинную стену в своем доме. Длина этой стены равна А метров, а высота - В метров. Рулон обоев имеет длину 12 метров и ширину K см. Составьте алгоритм и программу, которая определит стоимость обоев для всей стены, если цена одного рулона C руб.

+5
Ответы (1)
  1. 3 августа, 10:49
    0
    Var a, b, k, c: real; n: integer;

    begin

    readln (a, b, k, c) ;

    n:=round ((a*b) / (12*k/100) + 0.5) ;

    writeln (n*c:5:2) ;

    end.

    Пример:

    5 4 80 120

    360.00
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу в паскале со всеми строчками! Хозяин хочет оклеить обоями длинную стену в своем доме. Длина этой стены равна А метров, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
сделать программу в паскале по вычислению сколько рулонов нужно потратить на одну стену и сколько это будет стоить. Нужно ввести будет ширину и длину стенв, а также, ширину, длину и стоимость одного рулона обоев
Ответы (1)
Необходимо оклеить обоями комнату с заданными величинами длины и высоты стен. также заданы длина, ширина и цена одного рулона обоев. подсчитать суммарные расходы в денежном выражении.
Ответы (1)
Требуется оклеить обоями стены комнаты, длина которой 5 м, ширина - 3 м, а высота - 2,8 м. Хватит ли 8 рулонов обоев размером 10 м на 0,5 м для оклейки комнаты, если отходы не превосходят 5%, а окна и двери составляют 25% общей площади стен комнаты.
Ответы (1)
Рассчитайте минимальное количество обоев и их стоимость, необходимое для оклейки жилой комнаты размером 4 х 4 х 2,5 метров. Рулон обоев имеет ширину 55 см и длину 10 м. (7 рулонов)
Ответы (1)
В программе паскаль нужно ввести высоту и ширину стены, также ввести стоимость длину и ширину обоев. Вывести сколько рулонов потребуется на одну стену. И в этой же программе вывести сколько будет стоить столько рулонов.
Ответы (1)