Задать вопрос
2 апреля, 03:49

Pascal ABC

Напишите процедуру которая выводит на экран все делители переданного ей числа (в одну строчку)

+3
Ответы (1)
  1. 2 апреля, 04:24
    0
    Var n, i:integer;

    begin

    read (n) ;

    for i:=1 to n do

    begin

    if (n mod i = 0) then write (i,' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal ABC Напишите процедуру которая выводит на экран все делители переданного ей числа (в одну строчку) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Pascal ABC. Написать процедуру, которая выводит на экран первые 3 элемента из массива, которые не равны друг другу. Или процедуру нахождения 3 максимальных элементов массива, которые не равны друг другу
Ответы (1)
Напишите процедуру, которая выводит на экран в столбик все цифры переданного ей числа, начиная с последней (PascalABC)
Ответы (2)
Как в C + + в процедуре вводить число с клавиатуры? вот на примере этой задачи, что у меня не так исправьте Напишите процедуру, которая выводит на экран в столбик все цифры переданного ей числа, начиная с последней #include using namespace std;
Ответы (1)
Написать процедуру, которая выводит на экран в столбик все цифры переданного ей числа, начиная с первого
Ответы (1)