Задать вопрос
7 октября, 19:49

Дан массив натуральных чисел. Найти сумму элементов, кратных данному K.

+5
Ответы (1)
  1. 7 октября, 21:38
    0
    program bb;

    uses crt;

    const n=30;

    var

    m:array[1 ... n]of integer;

    i, k, s:integer;

    begin

    clrscr;

    randomize;

    for i:=1 to n do begin

    m[i]:=i; write (m[i],' ') ;

    end;

    writeln;

    write ('K = ') ;

    read (k) ;

    writeln;

    s:=0;

    for i:=1 to n do

    if m[i] mod k = 0 then

    begin

    s:=s+m[i]; write (m[i],' ') ;

    end;

    writeln;

    writeln;

    writeln ('Сумма элементов кратных данному К = ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив натуральных чисел. Найти сумму элементов, кратных данному K. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)